summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/x86_64/Makefile.am
diff options
context:
space:
mode:
authorAmaan Cheval <amaan.cheval@gmail.com>2018-07-09 16:42:56 +0530
committerJoel Sherrill <joel@rtems.org>2018-07-11 15:22:44 -0500
commit76c03152e110dcb770253b54277811228e8f78df (patch)
tree961fe157e59b137d932c4feb7d275b6157f99da0 /cpukit/score/cpu/x86_64/Makefile.am
parentbsp/riscv: Add console support for NS16550 devices (diff)
downloadrtems-76c03152e110dcb770253b54277811228e8f78df.tar.bz2
bsp/x86_64: Minimal bootable BSP
Current state: - Basic context initialization and switching code. - Stubbed console (empty functions). - Mostly functional linker script (may need tweaks if we ever want to move away from the large code model (see: CPU_CFLAGS). - Fully functional boot, by using FreeBSD's bootloader to load RTEMS's ELF for UEFI-awareness. In short, the current state with this commit lets us boot, go through the system initialization functions, and then call user application's Init task too. Updates #2898.
Diffstat (limited to 'cpukit/score/cpu/x86_64/Makefile.am')
-rw-r--r--cpukit/score/cpu/x86_64/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/cpukit/score/cpu/x86_64/Makefile.am b/cpukit/score/cpu/x86_64/Makefile.am
new file mode 100644
index 0000000000..db4bd15cd5
--- /dev/null
+++ b/cpukit/score/cpu/x86_64/Makefile.am
@@ -0,0 +1,12 @@
+include $(top_srcdir)/automake/compile.am
+
+noinst_LIBRARIES = libscorecpu.a
+libscorecpu_a_SOURCES = cpu.c
+libscorecpu_a_SOURCES += ../no_cpu/cpucounterfrequency.c
+libscorecpu_a_SOURCES += ../no_cpu/cpucounterread.c
+libscorecpu_a_SOURCES += x86_64-context-initialize.c
+libscorecpu_a_SOURCES += x86_64-context-switch.S
+libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)
+
+include $(top_srcdir)/automake/local.am
+include $(srcdir)/headers.am