summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/unix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-04-13 15:03:04 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-04-13 15:03:04 +0000
commitbd00319d3910d49faea67726998ae27cffe59b57 (patch)
tree5004175b21504bcfe3126e33f9ddfcd8aafe9409 /cpukit/score/cpu/unix/Makefile.am
parent2004-04-13 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-bd00319d3910d49faea67726998ae27cffe59b57.tar.bz2
2004-04-13 Ralf Corsepius <ralf_corsepius@rtems.org>
* asm.h: New (stub file. For consistency with other ports, only). * Makefile.am: Add asm.h.
Diffstat (limited to '')
-rw-r--r--cpukit/score/cpu/unix/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/cpukit/score/cpu/unix/Makefile.am b/cpukit/score/cpu/unix/Makefile.am
index df8b677a16..5da21f5edc 100644
--- a/cpukit/score/cpu/unix/Makefile.am
+++ b/cpukit/score/cpu/unix/Makefile.am
@@ -6,6 +6,9 @@ include $(top_srcdir)/automake/compile.am
AM_CPPFLAGS += -DCPU_SYNC_IO
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = asm.h
+
include_rtems_scoredir = $(includedir)/rtems/score
include_rtems_score_HEADERS = rtems/score/types.h rtems/score/cpu.h \
rtems/score/unix.h
@@ -25,6 +28,15 @@ all-local: $(PREINSTALL_FILES) libscorecpu$(LIB_VARIANT).a
PREINSTALL_DIRS =
PREINSTALL_FILES =
+$(PROJECT_INCLUDE)/rtems/$(dirstamp):
+ @$(mkdir_p) $(PROJECT_INCLUDE)/rtems
+ @: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+
+$(PROJECT_INCLUDE)/rtems/asm.h: asm.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/asm.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/asm.h
+
$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems/score
@: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)