summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/unix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 04:38:56 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 04:38:56 +0000
commit60f7da25f03d3e6c97d05f4da619699a294e9219 (patch)
tree8e0ee9952408c4f6aabae9ae0f0252363fadaadf /cpukit/score/cpu/unix/Makefile.am
parent2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-60f7da25f03d3e6c97d05f4da619699a294e9219.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Remove TMPINSTALL_FILES.
Diffstat (limited to 'cpukit/score/cpu/unix/Makefile.am')
-rw-r--r--cpukit/score/cpu/unix/Makefile.am53
1 files changed, 2 insertions, 51 deletions
diff --git a/cpukit/score/cpu/unix/Makefile.am b/cpukit/score/cpu/unix/Makefile.am
index 34a5e275ee..a2e0135e43 100644
--- a/cpukit/score/cpu/unix/Makefile.am
+++ b/cpukit/score/cpu/unix/Makefile.am
@@ -1,53 +1,4 @@
-##
-## $Id$
-##
+2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
-ACLOCAL_AMFLAGS = -I ../../../aclocal
+ * Makefile.am: Remove TMPINSTALL_FILES.
-include $(top_srcdir)/../../../automake/multilib.am
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
-
-AM_CPPFLAGS += -DCPU_SYNC_IO $(LIBC_DEFINES)
-
-include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = rtems/score/types.h rtems/score/cpu.h \
- rtems/score/unix.h rtems/score/unixsize.h
-
-C_FILES = cpu.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-LIB = $(ARCH)/libscorecpu.a
-
-$(LIB): $(OBJS)
- $(make-library)
-
-all-local: $(ARCH) $(PREINSTALL_FILES) $(LIB) \
- $(TMPINSTALL_FILES)
-
-EXTRA_DIST = cpu.c
-
-PREINSTALL_FILES =
-
-$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
- @: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-
-$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/types.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/types.h
-
-$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/cpu.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
-
-$(PROJECT_INCLUDE)/rtems/score/unix.h: rtems/score/unix.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/unix.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/unix.h
-
-$(PROJECT_INCLUDE)/rtems/score/unixsize.h: rtems/score/unixsize.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/unixsize.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/unixsize.h
-
-include $(top_srcdir)/../../../automake/local.am