summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/unix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-19 07:29:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-19 07:29:05 +0000
commit3d1de205f620197d40ad019eb2d9e2dd5f0525c2 (patch)
treee4feaad3efa5aede8330a49535ef909658e24c77 /cpukit/score/cpu/unix/Makefile.am
parent2004-01-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-3d1de205f620197d40ad019eb2d9e2dd5f0525c2.tar.bz2
2004-01-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add PREINSTALL_DIRS.
Diffstat (limited to 'cpukit/score/cpu/unix/Makefile.am')
-rw-r--r--cpukit/score/cpu/unix/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/cpukit/score/cpu/unix/Makefile.am b/cpukit/score/cpu/unix/Makefile.am
index ea9bc94685..ca718d9e6f 100644
--- a/cpukit/score/cpu/unix/Makefile.am
+++ b/cpukit/score/cpu/unix/Makefile.am
@@ -25,12 +25,13 @@ libscorecpu_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
all-local: $(PREINSTALL_FILES) libscorecpu$(LIB_VARIANT).a
+PREINSTALL_DIRS =
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems/score
@: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/types.h
@@ -49,5 +50,6 @@ $(PROJECT_INCLUDE)/rtems/score/unixsize.h: rtems/score/unixsize.h $(PROJECT_INCL
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/unixsize.h
CLEANFILES += $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../automake/local.am