summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/sparc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-11-23 10:36:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-11-23 10:36:05 +0000
commitd6a444d3b3707ceba558bfbd276289de152b9b69 (patch)
tree158158d6b40c6393d724207d6fd6f482a1a62573 /cpukit/score/cpu/sparc/Makefile.am
parent2003-11-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d6a444d3b3707ceba558bfbd276289de152b9b69.tar.bz2
2003-11-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Don't use gmake rules for preinstallation.
Diffstat (limited to 'cpukit/score/cpu/sparc/Makefile.am')
-rw-r--r--cpukit/score/cpu/sparc/Makefile.am41
1 files changed, 23 insertions, 18 deletions
diff --git a/cpukit/score/cpu/sparc/Makefile.am b/cpukit/score/cpu/sparc/Makefile.am
index 3a7c07ca91..cfc8079de2 100644
--- a/cpukit/score/cpu/sparc/Makefile.am
+++ b/cpukit/score/cpu/sparc/Makefile.am
@@ -8,28 +8,11 @@ include $(top_srcdir)/../../../automake/multilib.am
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_INCLUDE):
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems:
- $(mkinstalldirs) $@
-
-$(PROJECT_INCLUDE)/rtems/score:
- $(mkinstalldirs) $@
-
include_HEADERS= asm.h
-PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = \
- rtems/score/sparc.h \
- rtems/score/cpu.h \
+include_rtems_score_HEADERS = rtems/score/sparc.h rtems/score/cpu.h \
rtems/score/types.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
C_FILES = cpu.c
OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
@@ -47,4 +30,26 @@ all-local: $(ARCH) $(PREINSTALL_FILES) $(LIB) \
EXTRA_DIST = cpu.c cpu_asm.S
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/asm.h: asm.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/asm.h
+
+$(PROJECT_INCLUDE)/rtems/score:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score
+
+$(PROJECT_INCLUDE)/rtems/score/sparc.h: rtems/score/sparc.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/sparc.h
+
+$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/types.h
+
include $(top_srcdir)/../../../automake/local.am