summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/sparc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-02-24 12:45:00 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-02-24 16:12:02 +0100
commita4bc90af4ee55e72b18de4b64da6338634490760 (patch)
tree64cd9a60f941054d469ce5061d9d77847de2e308 /cpukit/score/cpu/sparc/Makefile.am
parentscore: Fix thread TLS area initialization (diff)
downloadrtems-a4bc90af4ee55e72b18de4b64da6338634490760.tar.bz2
sparc: Fix CPU counter support
The SPARC processors supported by RTEMS have no built-in CPU counter support. We have to use some hardware counter module for this purpose. The BSP must provide a 32-bit register which contains the current CPU counter value and a function for the difference calculation. It can use for example the GPTIMER instance used for the clock driver.
Diffstat (limited to 'cpukit/score/cpu/sparc/Makefile.am')
-rw-r--r--cpukit/score/cpu/sparc/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/score/cpu/sparc/Makefile.am b/cpukit/score/cpu/sparc/Makefile.am
index 504a5752fe..c6ea1c3da9 100644
--- a/cpukit/score/cpu/sparc/Makefile.am
+++ b/cpukit/score/cpu/sparc/Makefile.am
@@ -11,6 +11,7 @@ include_rtems_score_HEADERS += rtems/score/cpuatomic.h
noinst_LIBRARIES = libscorecpu.a
libscorecpu_a_SOURCES = cpu.c cpu_asm.S
+libscorecpu_a_SOURCES += sparc-counter.c
libscorecpu_a_SOURCES += sparcv8-atomic.c
libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)