summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/sparc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-09-26 06:34:54 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-10-05 13:41:06 +0200
commit8776bb94197613a369b47b3adf4b2d4e0ba766ed (patch)
tree37f2177f56e8d758bc4433ea8f8d98851fa81a18 /cpukit/score/cpu/sparc/Makefile.am
parentdev/sc16is752: Deal with a baud of zero (diff)
downloadrtems-8776bb94197613a369b47b3adf4b2d4e0ba766ed.tar.bz2
score: Remove CPU_PROVIDES_IDLE_THREAD_BODY
Remove the CPU_PROVIDES_IDLE_THREAD_BODY option to avoid unnecessary conditional compilation. Close #3539.
Diffstat (limited to 'cpukit/score/cpu/sparc/Makefile.am')
-rw-r--r--cpukit/score/cpu/sparc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/score/cpu/sparc/Makefile.am b/cpukit/score/cpu/sparc/Makefile.am
index 2e0ab5999d..6c06ce0d11 100644
--- a/cpukit/score/cpu/sparc/Makefile.am
+++ b/cpukit/score/cpu/sparc/Makefile.am
@@ -3,8 +3,9 @@ include $(top_srcdir)/automake/compile.am
noinst_LIBRARIES = libscorecpu.a
libscorecpu_a_SOURCES =
libscorecpu_a_SOURCES += access_le.c
-libscorecpu_a_SOURCES += cpu.c
libscorecpu_a_SOURCES += cpu_asm.S
+libscorecpu_a_SOURCES += cpu.c
+libscorecpu_a_SOURCES += ../no_cpu/cpuidle.c
libscorecpu_a_SOURCES += sparc-access.S
libscorecpu_a_SOURCES += sparc-context-validate.S
libscorecpu_a_SOURCES += sparc-context-volatile-clobber.S