summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/sh/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-11 02:37:03 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-11 02:37:03 +0000
commitec8c1949f0221a7044e9ee9a083bad455b4e141a (patch)
tree28b717eaa55f5be914fa8c85d5de21a6f2f2fd1d /cpukit/score/cpu/sh/Makefile.am
parent2004-01-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ec8c1949f0221a7044e9ee9a083bad455b4e141a.tar.bz2
2004-01-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Convert to using automake compilation rules.
Diffstat (limited to 'cpukit/score/cpu/sh/Makefile.am')
-rw-r--r--cpukit/score/cpu/sh/Makefile.am21
1 files changed, 10 insertions, 11 deletions
diff --git a/cpukit/score/cpu/sh/Makefile.am b/cpukit/score/cpu/sh/Makefile.am
index ed8c135863..effd7d02fe 100644
--- a/cpukit/score/cpu/sh/Makefile.am
+++ b/cpukit/score/cpu/sh/Makefile.am
@@ -5,8 +5,7 @@
ACLOCAL_AMFLAGS = -I ../../../aclocal
include $(top_srcdir)/../../../automake/multilib.am
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
+include $(top_srcdir)/../../../automake/amcompile.am
include_HEADERS= asm.h
@@ -14,17 +13,17 @@ include_rtems_scoredir = $(includedir)/rtems/score
include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/types.h \
rtems/score/sh.h rtems/score/sh_io.h
-C_FILES = cpu.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+EXTRA_LIBRARIES = libscorecpu.a
+CLEANFILES = libscorecpu.a
+libscorecpu_a_SOURCES = cpu.c
+libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-LIB = $(ARCH)/libscorecpu.a
+EXTRA_LIBRARIES += libscorecpu_g.a
+CLEANFILES += libscorecpu_g.a
+libscorecpu_g_a_SOURCES = $(libscorecpu_a_SOURCES)
+libscorecpu_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-$(LIB): $(OBJS)
- $(make-library)
-
-all-local: $(PREINSTALL_FILES) $(LIB)
-
-EXTRA_DIST = cpu.c
+all-local: $(PREINSTALL_FILES) libscorecpu$(LIB_VARIANT).a
PREINSTALL_FILES =