summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/sh/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-09-26 06:34:54 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-10-05 13:41:06 +0200
commit8776bb94197613a369b47b3adf4b2d4e0ba766ed (patch)
tree37f2177f56e8d758bc4433ea8f8d98851fa81a18 /cpukit/score/cpu/sh/Makefile.am
parentdev/sc16is752: Deal with a baud of zero (diff)
downloadrtems-8776bb94197613a369b47b3adf4b2d4e0ba766ed.tar.bz2
score: Remove CPU_PROVIDES_IDLE_THREAD_BODY
Remove the CPU_PROVIDES_IDLE_THREAD_BODY option to avoid unnecessary conditional compilation. Close #3539.
Diffstat (limited to 'cpukit/score/cpu/sh/Makefile.am')
-rw-r--r--cpukit/score/cpu/sh/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/score/cpu/sh/Makefile.am b/cpukit/score/cpu/sh/Makefile.am
index 37188443ff..b4a125fd81 100644
--- a/cpukit/score/cpu/sh/Makefile.am
+++ b/cpukit/score/cpu/sh/Makefile.am
@@ -4,6 +4,7 @@ noinst_LIBRARIES = libscorecpu.a
libscorecpu_a_SOURCES = cpu.c context.c
libscorecpu_a_SOURCES += ../no_cpu/cpucounterfrequency.c
libscorecpu_a_SOURCES += ../no_cpu/cpucounterread.c
+libscorecpu_a_SOURCES += ../no_cpu/cpuidle.c
libscorecpu_a_SOURCES += sh-exception-frame-print.c
libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS)