summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/sh/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 13:02:24 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 13:02:24 +0000
commit7fccd6d655f73d450956d7b063521d3a4953b3f8 (patch)
treeecc355ce3d98baa92f68e86a707873bd648f2106 /cpukit/score/cpu/sh/Makefile.am
parent2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-7fccd6d655f73d450956d7b063521d3a4953b3f8.tar.bz2
2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Use mkdir_p. Remove dirs from PREINSTALL_FILES.
Diffstat (limited to '')
-rw-r--r--cpukit/score/cpu/sh/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/cpukit/score/cpu/sh/Makefile.am b/cpukit/score/cpu/sh/Makefile.am
index 098fed44ec..ed8c135863 100644
--- a/cpukit/score/cpu/sh/Makefile.am
+++ b/cpukit/score/cpu/sh/Makefile.am
@@ -29,18 +29,16 @@ EXTRA_DIST = cpu.c
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)
+ @$(mkdir_p) $(PROJECT_INCLUDE)
@: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
$(PROJECT_INCLUDE)/asm.h: asm.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/asm.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/asm.h
$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
+ @$(mkdir_p) $(PROJECT_INCLUDE)/rtems/score
@: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/cpu.h