summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/m68k/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-11 05:40:53 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-11 05:40:53 +0000
commitf08808ee913161c80d03817cd6b213dc1c184259 (patch)
tree0c556710c40b4d994771a911809b48ce8f2f1721 /cpukit/score/cpu/m68k/Makefile.am
parent2004-01-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f08808ee913161c80d03817cd6b213dc1c184259.tar.bz2
2004-01-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Include compile.am, again.
Diffstat (limited to 'cpukit/score/cpu/m68k/Makefile.am')
-rw-r--r--cpukit/score/cpu/m68k/Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/cpukit/score/cpu/m68k/Makefile.am b/cpukit/score/cpu/m68k/Makefile.am
index 1300d2943d..f4a32e66ec 100644
--- a/cpukit/score/cpu/m68k/Makefile.am
+++ b/cpukit/score/cpu/m68k/Makefile.am
@@ -5,8 +5,15 @@
ACLOCAL_AMFLAGS = -I ../../../aclocal
include $(top_srcdir)/../../../automake/multilib.am
-include $(top_srcdir)/../../../automake/amcompile.am
-include $(top_srcdir)/../../../automake/lib.am
+include $(top_srcdir)/../../../automake/compile.am
+
+EXTRA_LIBRARIES = libscorecpu.a
+CLEANFILES = libscorecpu.a
+libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+
+EXTRA_LIBRARIES += libscorecpu_g.a
+CLEANFILES += libscorecpu_g.a
+libscorecpu_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
include_HEADERS = asm.h m68302.h m68360.h qsm.h sim.h
@@ -14,15 +21,9 @@ include_rtems_scoredir = $(includedir)/rtems/score
include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/m68k.h \
rtems/score/types.h
-EXTRA_LIBRARIES = libscorecpu.a
-CLEANFILES = libscorecpu.a
libscorecpu_a_SOURCES = cpu.c cpu_asm.S
-libscorecpu_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-EXTRA_LIBRARIES += libscorecpu_g.a
-CLEANFILES += libscorecpu_g.a
libscorecpu_g_a_SOURCES = $(libscorecpu_a_SOURCES)
-libscorecpu_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
all-local: $(PREINSTALL_FILES) libscorecpu$(LIB_VARIANT).a