summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/i386/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 05:13:29 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 05:13:29 +0000
commitb17cce8681d5af5bcc23b456884730a4d43e4fa7 (patch)
tree49349619506d24e66ca6b64c9fb501b2010ee90e /cpukit/score/cpu/i386/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-b17cce8681d5af5bcc23b456884730a4d43e4fa7.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Restore file having been broken in last commit.
Diffstat (limited to 'cpukit/score/cpu/i386/Makefile.am')
-rw-r--r--cpukit/score/cpu/i386/Makefile.am67
1 files changed, 65 insertions, 2 deletions
diff --git a/cpukit/score/cpu/i386/Makefile.am b/cpukit/score/cpu/i386/Makefile.am
index a2e0135e43..6c7f174b92 100644
--- a/cpukit/score/cpu/i386/Makefile.am
+++ b/cpukit/score/cpu/i386/Makefile.am
@@ -1,4 +1,67 @@
-2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
+##
+## $Id$
+##
- * Makefile.am: Remove TMPINSTALL_FILES.
+ACLOCAL_AMFLAGS = -I ../../../aclocal
+include $(top_srcdir)/../../../automake/multilib.am
+include $(top_srcdir)/../../../automake/compile.am
+include $(top_srcdir)/../../../automake/lib.am
+
+include_HEADERS= asm.h
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/i386.h \
+ rtems/score/types.h rtems/score/interrupts.h rtems/score/registers.h \
+ rtems/score/idtr.h
+
+LIB = $(ARCH)/libscorecpu.a
+
+C_FILES = cpu.c
+OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+
+S_FILES = cpu_asm.S
+OBJS += $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(PREINSTALL_FILES) $(LIB)
+
+EXTRA_DIST = cpu.c cpu_asm.S
+
+PREINSTALL_FILES =
+
+$(PROJECT_INCLUDE)/asm.h: asm.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/asm.h
+
+$(PROJECT_INCLUDE)/rtems/score:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score
+
+$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
+
+$(PROJECT_INCLUDE)/rtems/score/i386.h: rtems/score/i386.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/i386.h
+
+$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/types.h
+
+$(PROJECT_INCLUDE)/rtems/score/interrupts.h: rtems/score/interrupts.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/interrupts.h
+
+$(PROJECT_INCLUDE)/rtems/score/registers.h: rtems/score/registers.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/registers.h
+
+$(PROJECT_INCLUDE)/rtems/score/idtr.h: rtems/score/idtr.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/idtr.h
+
+include $(top_srcdir)/../../../automake/local.am