summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/i386/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-30 22:46:17 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-30 22:46:17 +0000
commit845fac33843b9ce0b2f532700457754e2849b922 (patch)
tree277f6c2b6dba64e9babc9d0f481d7d48b0d41038 /cpukit/score/cpu/i386/Makefile.am
parent2001-01-30 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-845fac33843b9ce0b2f532700457754e2849b922.tar.bz2
2001-01-30 Joel Sherrill <joel@OARcorp.com>
* Makefile.am: Corrected so .h files from rtems/score/ are installed.
Diffstat (limited to '')
-rw-r--r--cpukit/score/cpu/i386/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/cpukit/score/cpu/i386/Makefile.am b/cpukit/score/cpu/i386/Makefile.am
index 8c5a20f82e..e43fb9ee03 100644
--- a/cpukit/score/cpu/i386/Makefile.am
+++ b/cpukit/score/cpu/i386/Makefile.am
@@ -5,8 +5,6 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I ../../../../../../aclocal
-SUBDIRS = rtems
-
REL = $(ARCH)/rtems-cpu.rel
C_FILES = cpu.c
@@ -29,13 +27,28 @@ $(PROJECT_INCLUDE):
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
$(INSTALL_DATA) $< $@
$(REL): $(rtems_cpu_rel_OBJECTS)
$(make-rel)
-PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = \
+ rtems/score/cpu.h \
+ rtems/score/i386.h \
+ rtems/score/i386types.h
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE) \
+ $(include_HEADERS:%=$(PROJECT_INCLUDE)/%) \
+ $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).o