summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/h8300/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-11 17:08:38 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-11 17:08:38 +0000
commit53021d4abb385455ec445fd53744427c095dd7c5 (patch)
tree0b6cee839acaff783748574f2f6ed814ac939786 /cpukit/score/cpu/h8300/Makefile.am
parent2002-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-53021d4abb385455ec445fd53744427c095dd7c5.tar.bz2
2002-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Require autoconf-2.57 + automake-1.7.2. * Makefile.am: Eliminate C_O_FILES, S_O_FILES, libscorecpu_a_OBJECTS.
Diffstat (limited to 'cpukit/score/cpu/h8300/Makefile.am')
-rw-r--r--cpukit/score/cpu/h8300/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/cpukit/score/cpu/h8300/Makefile.am b/cpukit/score/cpu/h8300/Makefile.am
index 1cc419c26b..221b211011 100644
--- a/cpukit/score/cpu/h8300/Makefile.am
+++ b/cpukit/score/cpu/h8300/Makefile.am
@@ -32,16 +32,14 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
$(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
C_FILES = cpu.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
S_FILES = cpu_asm.S
-S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
+OBJS += $(S_FILES:%.S=$(ARCH)/%.$(OBJEXT))
LIB = $(ARCH)/libscorecpu.a
-libscorecpu_a_OBJECTS = $(C_O_FILES) $(S_O_FILES)
-
-$(LIB): $(libscorecpu_a_OBJECTS)
+$(LIB): $(OBJS)
$(make-library)
all-local: $(ARCH) $(PREINSTALL_FILES) $(LIB) \