summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/h8300/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 06:11:27 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-01 06:11:27 +0000
commit49720ad0da9591e9592e7e53ab55921332e089dc (patch)
treebf400ff1578b2e5bfaca1e36ac8dd561e3a04ba6 /cpukit/score/cpu/h8300/Makefile.am
parent2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-49720ad0da9591e9592e7e53ab55921332e089dc.tar.bz2
2003-12-01 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am:Restore further parts having been lost.
Diffstat (limited to 'cpukit/score/cpu/h8300/Makefile.am')
-rw-r--r--cpukit/score/cpu/h8300/Makefile.am26
1 files changed, 16 insertions, 10 deletions
diff --git a/cpukit/score/cpu/h8300/Makefile.am b/cpukit/score/cpu/h8300/Makefile.am
index ac4573ae3f..2ee08301ca 100644
--- a/cpukit/score/cpu/h8300/Makefile.am
+++ b/cpukit/score/cpu/h8300/Makefile.am
@@ -31,24 +31,30 @@ EXTRA_DIST = cpu.c cpu_asm.S
PREINSTALL_FILES =
-$(PROJECT_INCLUDE)/asm.h: asm.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)
+ @: > $(PROJECT_INCLUDE)/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
+
+$(PROJECT_INCLUDE)/asm.h: asm.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/asm.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/asm.h
-$(PROJECT_INCLUDE)/rtems/score:
+$(PROJECT_INCLUDE)/rtems/score/$(dirstamp):
@$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/score
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score
+ @: > $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
-$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/cpu.h: rtems/score/cpu.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/cpu.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/cpu.h
-$(PROJECT_INCLUDE)/rtems/score/h8300.h: rtems/score/h8300.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/h8300.h: rtems/score/h8300.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/h8300.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/h8300.h
-$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/score/types.h: rtems/score/types.h $(PROJECT_INCLUDE)/rtems/score/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/types.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/types.h
include $(top_srcdir)/../../../automake/local.am