summaryrefslogtreecommitdiffstats
path: root/cpukit/score/cpu/Makefile.am
diff options
context:
space:
mode:
authorHesham Almatary <heshamelmatary@gmail.com>2017-10-27 15:18:40 +1100
committerHesham Almatary <heshamelmatary@gmail.com>2017-11-01 10:10:27 +1100
commit11ff3a9e72ca261a6024b16c34c6fb35054fd53a (patch)
treeffddc78ce5f3ceff414fa7551f49c7ccb5510672 /cpukit/score/cpu/Makefile.am
parenttestsuite: Add bspIo for a local printk. (diff)
downloadrtems-11ff3a9e72ca261a6024b16c34c6fb35054fd53a.tar.bz2
cpukit: RISC-V - make riscv32 code work for riscv64 - v2
* Use #ifdefs for 32/64 bit code * Use unsigned long which is 32-bit on riscv32 and 64-bit on riscv64 (register size) * Move the code to a new shared riscv folder to be shared between riscv32 and riscv64 * Rename RTEMS_CPU extracted from command line to shared riscv target s/riscv*/riscv Update #3109
Diffstat (limited to 'cpukit/score/cpu/Makefile.am')
-rw-r--r--cpukit/score/cpu/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/cpu/Makefile.am b/cpukit/score/cpu/Makefile.am
index 73c65401f6..4ddbdf0d05 100644
--- a/cpukit/score/cpu/Makefile.am
+++ b/cpukit/score/cpu/Makefile.am
@@ -14,7 +14,7 @@ DIST_SUBDIRS += nios2
DIST_SUBDIRS += no_cpu
DIST_SUBDIRS += or1k
DIST_SUBDIRS += powerpc
-DIST_SUBDIRS += riscv32
+DIST_SUBDIRS += riscv
DIST_SUBDIRS += sh
DIST_SUBDIRS += sparc
DIST_SUBDIRS += sparc64