summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-08-14 21:01:30 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-08-14 21:01:30 +0000
commitff08b8087887bc1ae8d9f22f3a21c62e46477312 (patch)
treedb90a83cc219fdfa6fd708484c0966acc0f2b434 /cpukit/score/Makefile.am
parent2003-08-14 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-ff08b8087887bc1ae8d9f22f3a21c62e46477312.tar.bz2
2003-08-14 Joel Sherrill <joel@OARcorp.com>
* Makefile.am, include/rtems/score/object.h, include/rtems/score/objectmp.h, src/objectmp.c, src/objectnametoid.c: Added ID to name lookup service and changed name of id/name translation status code. This propagated to multiple functions. The user API service added was rtems_object_id_to_name() * src/objectidtoname.c: New file.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 40efdf999c..31b3c68453 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -132,7 +132,8 @@ OBJECT_C_FILES = src/object.c src/objectallocate.c src/objectallocatebyindex.c \
src/objectcopynameraw.c src/objectcopynamestring.c src/objectextendinformation.c \
src/objectfree.c src/objectget.c src/objectgetisr.c src/objectgetbyindex.c \
src/objectgetnext.c src/objectinitializeinformation.c src/objectnametoid.c \
- src/objectshrinkinformation.c src/objectgetnoprotection.c
+ src/objectshrinkinformation.c src/objectgetnoprotection.c \
+ src/objectidtoname.c
THREAD_C_FILES = src/thread.c src/threadchangepriority.c src/threadclearstate.c \
src/threadclose.c src/threadcreateidle.c src/threaddelayended.c src/threaddispatch.c \