summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-04-04 13:54:10 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-04-04 13:54:10 +0000
commitfc054cabb5bed1dfd99a3fa96297ba3293dd9f1d (patch)
tree2f8a54da1dedcc1f47081589b0773a1b7a0c7350 /cpukit/score/Makefile.am
parent2007-04-02 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-fc054cabb5bed1dfd99a3fa96297ba3293dd9f1d.tar.bz2
2007-04-04 Joel Sherrill <joel@OARcorp.com>
* score/Makefile.am, score/include/rtems/score/tod.h, score/inline/rtems/score/tod.inl: Make _TOD_Tickle_ticks a real non-inlined routine. It should only be used once so there is little advantage to inlining it. * score/src/coretodtickle.c: New file.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 59b227a29a..a4b217fda1 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -139,9 +139,12 @@ libscore_a_SOURCES += src/threadq.c src/threadqdequeue.c \
src/threadqfirstpriority.c src/threadqflush.c src/threadqrequeue.c \
src/threadqtimeout.c
+## TIMESPEC_C_FILES
+## libscore_a_SOURCES +=
+
## TOD_C_FILES
libscore_a_SOURCES += src/coretod.c src/coretodset.c src/coretodget.c \
- src/coretodgetuptime.c
+ src/coretodgetuptime.c src/coretodtickle.c
## WATCHDOG_C_FILES
libscore_a_SOURCES += src/watchdog.c src/watchdogadjust.c \