summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2016-04-28 06:51:25 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2016-05-02 07:46:16 +0200
commitd5cc9fd6f1fd6268c4872e4145fb27fa5a08a16e (patch)
treecba79b0567eeca94046014bdab0073de46eea4e0 /cpukit/score/Makefile.am
parentscore: Delete __RTEMS_STRICT_ORDER_MUTEX__ (diff)
downloadrtems-d5cc9fd6f1fd6268c4872e4145fb27fa5a08a16e.tar.bz2
score: __RTEMS_DO_NOT_INLINE_CORE_MUTEX_SEIZE__
Delete __RTEMS_DO_NOT_INLINE_CORE_MUTEX_SEIZE__ as a preparation to restructure the CORE mutex variants and reduce the branch complexity.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 455c99d13d..c2aec62293 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -176,8 +176,7 @@ libscore_a_SOURCES += src/coremsg.c src/coremsgbroadcast.c \
## CORE_MUTEX_C_FILES
libscore_a_SOURCES += src/coremutex.c \
- src/coremutexseize.c src/coremutexsurrender.c \
- src/coremutexseizeintr.c
+ src/coremutexseize.c src/coremutexsurrender.c
## CORE_PERCPU_C_FILES
libscore_a_SOURCES += src/percpu.c