summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-05-17 19:48:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-05-17 19:48:44 +0000
commitba7bc099a86deef7c5b0f00887a315262e8f7974 (patch)
tree83a4a6c0db1840dda210a0c9e92732c38acff76b /cpukit/score/Makefile.am
parent2011-05-17 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-ba7bc099a86deef7c5b0f00887a315262e8f7974.tar.bz2
2011-05-17 Joel Sherrill <joel.sherrill@oarcorp.com>
PR 1789/cpukit * sapi/include/confdefs.h, score/Makefile.am, score/preinstall.am: Add Simple SMP Priority Scheduler. * score/include/rtems/score/schedulersimplesmp.h, score/src/schedulersimplesmpblock.c, score/src/schedulersimplesmpschedule.c, score/src/schedulersimplesmpunblock.c: New files.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 585563a12e..38df872557 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -12,7 +12,11 @@ SUBDIRS = cpu
include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = include/rtems/debug.h include/rtems/system.h \
- include/rtems/seterr.h include/rtems/bspsmp.h
+ include/rtems/seterr.h
+
+if HAS_SMP
+include_rtems_HEADERS += include/rtems/bspsmp.h
+endif
include_rtems_scoredir = $(includedir)/rtems/score
@@ -36,14 +40,13 @@ include_rtems_score_HEADERS = include/rtems/score/address.h \
include/rtems/score/timestamp64.h include/rtems/score/tod.h \
include/rtems/score/tqdata.h include/rtems/score/userext.h \
include/rtems/score/watchdog.h include/rtems/score/wkspace.h \
- include/rtems/score/cpuopts.h include/rtems/score/basedefs.h
+ include/rtems/score/cpuopts.h include/rtems/score/basedefs.h
if HAS_SMP
include_rtems_score_HEADERS += \
include/rtems/score/smplock.h include/rtems/score/smp.h
endif
-
if HAS_PTHREADS
include_rtems_score_HEADERS += include/rtems/score/corespinlock.h \
include/rtems/score/corerwlock.h
@@ -56,6 +59,10 @@ include_rtems_score_HEADERS += include/rtems/score/mpci.h \
include/rtems/score/threadmp.h
endif
+if HAS_SMP
+include_rtems_score_HEADERS += include/rtems/score/schedulersimplesmp.h
+endif
+
## inline
include_rtems_score_HEADERS += inline/rtems/score/address.inl \
inline/rtems/score/chain.inl inline/rtems/score/corebarrier.inl \
@@ -97,7 +104,9 @@ libscore_a_SOURCES += src/mpci.c src/objectmp.c src/threadmp.c
endif
if HAS_SMP
-libscore_a_SOURCES += src/smp.c src/smplock.c
+libscore_a_SOURCES += src/smp.c src/smplock.c \
+ src/schedulersimplesmpblock.c src/schedulersimplesmpschedule.c \
+ src/schedulersimplesmpunblock.c
endif
## CORE_APIMUTEX_C_FILES