summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-06-06 15:41:00 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-06-14 16:26:08 +0200
commita936aa49b5171915aee6c7cecc0b84a3912fd692 (patch)
treeec2c8adb89b3659a583e2c208c69dba3d4558073 /cpukit/score/Makefile.am
parentscheduler: Simplify simple scheduler (diff)
downloadrtems-a936aa49b5171915aee6c7cecc0b84a3912fd692.tar.bz2
scheduler: New simple SMP scheduler implementation
The new Simple SMP Scheduler allocates a processor for the processor count highest priority ready threads. The thread priority and position in the ready chain are the only information to determine the scheduling decision. Threads with an allocated processor are in the scheduled chain. After initialization the scheduled chain has exactly processor count nodes. Each processor has exactly one allocated thread after initialization. All enqueue and extract operations may exchange threads with the scheduled chain. One thread will be added and another will be removed. The scheduled and ready chain is ordered according to the thread priority order. The chain insert operations are O(count of ready threads), thus this scheduler is unsuitable for most real-time applications. The thread preempt mode will be ignored.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index f072cf3cbc..3f6e686ad9 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -134,9 +134,9 @@ libscore_a_SOURCES += src/mpci.c src/objectmp.c src/threadmp.c
endif
if HAS_SMP
-libscore_a_SOURCES += src/isrsmp.c src/smp.c \
- src/schedulersimplesmpblock.c src/schedulersimplesmpschedule.c \
- src/schedulersimplesmpunblock.c
+libscore_a_SOURCES += src/isrsmp.c
+libscore_a_SOURCES += src/schedulersimplesmp.c
+libscore_a_SOURCES += src/smp.c
endif
## CORE_APIMUTEX_C_FILES