summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-11-09 15:21:20 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-11-09 15:21:20 +0000
commit8fd28d83028fb044c67c7f7a5b06d7c2e7e8690c (patch)
tree9ea086d798ce737b20c650daa104ec17a2b26a83 /cpukit/score/Makefile.am
parentgcc-3.4.6-2. (diff)
downloadrtems-8fd28d83028fb044c67c7f7a5b06d7c2e7e8690c.tar.bz2
2007-11-09 Joel Sherrill <joel.sherrill@OARcorp.com>
* sapi/src/exinit.c, score/Makefile.am, score/include/rtems/score/apimutex.h: API Mutex calls should never have been inlined. Inlining them lead to many inlined copies of core mutex lock. This lead to over 2K savings in the SPARC/ERC32 minimum.exe. * score/src/apimutex.c, score/src/apimutexallocate.c, score/src/apimutexlock.c, score/src/apimutexunlock.c: New files.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index cdf975ea5c..eefe200510 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -73,6 +73,10 @@ if HAS_MP
libscore_a_SOURCES += src/mpci.c src/objectmp.c src/threadmp.c
endif
+## CORE_APIMUTEX_C_FILES
+libscore_a_SOURCES += src/apimutex.c src/apimutexallocate.c \
+ src/apimutexlock.c src/apimutexunlock.c
+
## CORE_BARRIER_C_FILES
libscore_a_SOURCES += src/corebarrier.c src/corebarrierrelease.c \
src/corebarrierwait.c