summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2014-03-19 15:20:01 -0500
committerJennifer Averett <jennifer.averett@oarcorp.com>2014-04-03 10:48:56 -0500
commit56c396ba476a48c4f2a4fdd488f704dd76dbddec (patch)
treed46a5658806776a34fcd5604f815ecdd87040a07 /cpukit/score/Makefile.am
parentscore: score: Add get/set affinity to Scheduler Framework. (diff)
downloadrtems-56c396ba476a48c4f2a4fdd488f704dd76dbddec.tar.bz2
score: Add priority affinity smp scheduler.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index a09ddc3f09..07cb52022b 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -109,6 +109,7 @@ endif
if HAS_SMP
include_rtems_score_HEADERS += include/rtems/score/atomic.h
include_rtems_score_HEADERS += include/rtems/score/cpustdatomic.h
+include_rtems_score_HEADERS += include/rtems/score/schedulerpriorityaffinitysmp.h
include_rtems_score_HEADERS += include/rtems/score/schedulersimplesmp.h
endif
@@ -125,6 +126,7 @@ endif
if HAS_SMP
libscore_a_SOURCES += src/profilingsmplock.c
+libscore_a_SOURCES += src/schedulerpriorityaffinitysmp.c
libscore_a_SOURCES += src/schedulerprioritysmp.c
libscore_a_SOURCES += src/schedulersimplesmp.c
libscore_a_SOURCES += src/smp.c