summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-03-02 12:23:20 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-03-02 12:23:48 +0100
commit4ccb79bc1b9137f5fd7427ddfc0123c872e6c093 (patch)
tree0f2780560889ec61743e39cb3bc1318e576b7274 /cpukit/score/Makefile.am
parentARM: Add BSP_START_NEEDS_REGISTER_INITIALIZATION (diff)
downloadrtems-4ccb79bc1b9137f5fd7427ddfc0123c872e6c093.tar.bz2
score: Enable SMP barriers for all configurations
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 7bb7dabb1d..a2d440b255 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -293,7 +293,6 @@ libscore_a_SOURCES += src/threadglobalconstruction.c
libscore_a_SOURCES += src/threadyield.c
if HAS_SMP
-libscore_a_SOURCES += src/smpbarrierwait.c
libscore_a_SOURCES += src/threaddispatchdisablelevel.c
endif
@@ -343,6 +342,7 @@ libscore_a_SOURCES += src/debugisownerofallocator.c
libscore_a_SOURCES += src/profilingisrentryexit.c
libscore_a_SOURCES += src/once.c
libscore_a_SOURCES += src/resourceiterate.c
+libscore_a_SOURCES += src/smpbarrierwait.c
EXTRA_DIST = src/Unlimited.txt