summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2013-12-24 16:38:42 +1100
committerChris Johns <chrisj@rtems.org>2013-12-24 16:46:19 +1100
commit2d1bdc8f797db5ab6e3ba6945befaf73d9062798 (patch)
treee8a3eecc64c589a9d0495790e09092dc572f36cf /cpukit/score/Makefile.am
parentmips/shared: added new doxygen (diff)
downloadrtems-2d1bdc8f797db5ab6e3ba6945befaf73d9062798.tar.bz2
cpukit/rtems: Add rtems_clock_get_uptime_nanoseconds to the RTEMS API.
Add Timestamp support in the score to return a timestamp in nanoseconds. Add a test. Update the RTEMS API documentation.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 4570ffd16a..4b221294d2 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -215,7 +215,7 @@ libscore_a_SOURCES += src/schedulersimple.c \
src/schedulersimplereadyqueueenqueuefirst.c \
src/schedulersimpleschedule.c \
src/schedulersimpleunblock.c \
- src/schedulersimpleyield.c
+ src/schedulersimpleyield.c
## SCHEDULEREDF_C_FILES
libscore_a_SOURCES += src/scheduleredf.c \
@@ -275,7 +275,7 @@ libscore_a_SOURCES += src/thread.c src/threadchangepriority.c \
src/threadstackallocate.c src/threadstackfree.c src/threadstart.c \
src/threadstartmultitasking.c src/iterateoverthreads.c \
src/threadblockingoperationcancel.c
-
+
if HAS_SMP
libscore_a_SOURCES += src/threaddispatchdisablelevel.c
endif
@@ -294,7 +294,7 @@ libscore_a_SOURCES += src/threadq.c src/threadqdequeue.c \
libscore_a_SOURCES += src/timespecaddto.c src/timespecfromticks.c \
src/timespecisvalid.c src/timespeclessthan.c \
src/timespecsubtract.c src/timespectoticks.c src/timespecdivide.c \
- src/timespecdividebyinteger.c
+ src/timespecdividebyinteger.c src/timespecgetasnanoseconds.c
## TIMESTAMP_INT64_C_FILES
libscore_a_SOURCES += src/ts64addto.c src/ts64dividebyinteger.c \