summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2012-02-10 10:36:26 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-02-10 10:42:58 +0100
commit28a08877ea961b0440b121b4617919136d6f342d (patch)
treec20ca716fad23ca298e98cf03bd8262150c8108e /cpukit/score/Makefile.am
parentMoved empty test in front of busy tests (diff)
downloadrtems-28a08877ea961b0440b121b4617919136d6f342d.tar.bz2
Added support functions for greedy heap allocation
Various tests must check program paths that result due to failed memory allocations from the heap. To avoid tinkering with internal heap structures throughout the test code these functions should be used.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 13c31826b9..597da3e0cc 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -181,7 +181,8 @@ endif
## HEAP_C_FILES
libscore_a_SOURCES += src/heap.c src/heapallocate.c src/heapextend.c \
src/heapfree.c src/heapsizeofuserarea.c src/heapwalk.c src/heapgetinfo.c \
- src/heapgetfreeinfo.c src/heapresizeblock.c src/heapiterate.c
+ src/heapgetfreeinfo.c src/heapresizeblock.c src/heapiterate.c \
+ src/heapgreedy.c
## OBJECT_C_FILES
libscore_a_SOURCES += src/objectallocate.c src/objectclose.c \