summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-03-07 13:07:02 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-03-07 13:21:00 +0100
commit088acbb01fc5060f687e4776f8fc6862060d3aa8 (patch)
treea9445b3bb7de49f8956a0b12cedc0469e1e9bda5 /cpukit/score/Makefile.am
parentpowerpc: Optimize AltiVec context switch (diff)
downloadrtems-088acbb01fc5060f687e4776f8fc6862060d3aa8.tar.bz2
score: Fix scheduler yield in SMP configurations
Check that no ask help request is registered during unblock and yield scheduler operations. There is no need to ask for help if a scheduled thread yields, since this is already covered by the pre-emption detection. Update #2556.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 953f1eb195..0288c5393a 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -161,6 +161,7 @@ libscore_a_SOURCES += src/cpusetprintsupport.c
libscore_a_SOURCES += src/schedulerdefaultaskforhelp.c
libscore_a_SOURCES += src/schedulerdefaultgetaffinity.c
libscore_a_SOURCES += src/schedulerdefaultsetaffinity.c
+libscore_a_SOURCES += src/schedulersmp.c
libscore_a_SOURCES += src/schedulersmpstartidle.c
endif