summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorGedare Bloom <gedare@rtems.org>2017-12-21 13:04:50 -0500
committerGedare Bloom <gedare@rtems.org>2018-03-23 11:33:59 -0400
commitb50468c6bff4e770aa038b9f87e514a2a1da906b (patch)
tree3313ec0f840e8ae24828dc33187adf71682d07b4 /cpukit/score/Makefile.am
parentscore: replace current and real priority with priority node (diff)
downloadrtems-b50468c6bff4e770aa038b9f87e514a2a1da906b.tar.bz2
score: add Inherited_priorities priority queue and functions
Adds enqueue, dequeue, requeue, evaluate, and release functions for the thread priority node priority queue of inherited priorities. Add calls to these functions as needed to maintain the priority queue due to blocking, unblocking, and priority changes. Closes #3359.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index c61e1dcca8..06d323444c 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -154,7 +154,8 @@ libscore_a_SOURCES += src/thread.c src/threadchangepriority.c \
src/threadstackallocate.c src/threadstackfree.c src/threadstart.c \
src/threadstartmultitasking.c src/threadsuspend.c \
src/threadtickletimeslice.c src/threadyieldprocessor.c \
- src/iterateoverthreads.c src/threadblockingoperationcancel.c
+ src/iterateoverthreads.c src/threadblockingoperationcancel.c \
+ src/threadprioritynode.c
## THREAD_C_FILES only used by ITRON API
if LIBITRON