summaryrefslogtreecommitdiffstats
path: root/cpukit/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-12-16 20:53:34 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-12-16 20:53:34 +0000
commit26fb4aadcd2c3159ecca7493c1f3d02cc02149ba (patch)
treee352a00acf541d65590f7c250b9fd9cd61f4e70d /cpukit/score/Makefile.am
parent2008-12-16 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-26fb4aadcd2c3159ecca7493c1f3d02cc02149ba.tar.bz2
2008-12-16 Joel Sherrill <joel.sherrill@oarcorp.com>
* libblock/src/bdbuf.c, libmisc/capture/capture-cli.c, libmisc/capture/capture.c, libmisc/mw-fb/mw_uid.c, rtems/include/rtems/rtems/support.h, score/Makefile.am, score/include/rtems/score/tod.h, score/src/coretod.c, score/src/coretodtickle.c: Eliminate all public use of TOD conversion routines. Eliminate _TOD_Microseconds_per_tick and let every place use the field directly from the Configuration Table. This required moving some methods from macros to bodies. * score/src/coretodmsecstoticks.c, score/src/coretodtickspersec.c, score/src/coretodusectoticks.c: New files.
Diffstat (limited to 'cpukit/score/Makefile.am')
-rw-r--r--cpukit/score/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/score/Makefile.am b/cpukit/score/Makefile.am
index 82ebc5e20d..81e2e525f7 100644
--- a/cpukit/score/Makefile.am
+++ b/cpukit/score/Makefile.am
@@ -178,7 +178,8 @@ libscore_a_SOURCES += src/ts64addto.c src/ts64dividebyinteger.c \
## TOD_C_FILES
libscore_a_SOURCES += src/coretod.c src/coretodset.c src/coretodget.c \
- src/coretodgetuptime.c src/coretodgetuptimetimespec.c src/coretodtickle.c
+ src/coretodgetuptime.c src/coretodgetuptimetimespec.c src/coretodtickle.c \
+ src/coretodmsecstoticks.c src/coretodtickspersec.c src/coretodusectoticks.c
## WATCHDOG_C_FILES
libscore_a_SOURCES += src/watchdog.c src/watchdogadjust.c \