summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/src/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 13:29:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 13:29:04 +0000
commitfba12eb6ff4a91fcbac1c43dd3196114cc12756b (patch)
tree34477c9b77ceab1ee81e0ea4a9ee9a6e3a3975cf /cpukit/sapi/src/Makefile.am
parentAdded projects chapter to FAQ. (diff)
downloadrtems-fba12eb6ff4a91fcbac1c43dd3196114cc12756b.tar.bz2
Patch rtems-rc-19991117-11.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
to convert the libc directory to automake and "dozens of small fixes for Makefile.ins/configure.ins below c/src/lib."
Diffstat (limited to '')
-rw-r--r--cpukit/sapi/src/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/cpukit/sapi/src/Makefile.am b/cpukit/sapi/src/Makefile.am
new file mode 100644
index 0000000000..d4c32b0ee7
--- /dev/null
+++ b/cpukit/sapi/src/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+C_FILES = debug.c entrytable.c extension.c fatal.c exinit.c io.c itronapi.c \
+ posixapi.c rtemsapi.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+SRCS = $(C_FILES)
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+#
+# Add local stuff here using +=
+#
+
+AM_CPPFLAGS += -D__RTEMS_INSIDE__
+AM_CFLAGS += $(CFLAGS_OS_V)
+
+all: ${ARCH} ${OBJS}
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../automake/local.am