summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/src/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-12-09 07:29:18 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-12-09 07:29:18 +0000
commitf117cafc8a8e1361e9e34f1a38cf0edc2d8481ff (patch)
tree76f6f386798f58f0a21ab499473d75c8824f901b /cpukit/sapi/src/Makefile.am
parent2002-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f117cafc8a8e1361e9e34f1a38cf0edc2d8481ff.tar.bz2
2002-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/Makefile.am: Remove. * inline/Makefile.am: Remove. * macros/Makefile.am: Remove. * src/Makefile.am: Remove. * Makefile.am: Merge-in removed Makefile.ams.
Diffstat (limited to '')
-rw-r--r--cpukit/sapi/src/Makefile.am32
1 files changed, 0 insertions, 32 deletions
diff --git a/cpukit/sapi/src/Makefile.am b/cpukit/sapi/src/Makefile.am
deleted file mode 100644
index de8da93902..0000000000
--- a/cpukit/sapi/src/Makefile.am
+++ /dev/null
@@ -1,32 +0,0 @@
-##
-## $Id$
-##
-
-LIB=$(ARCH)/libsapi.a
-
-EXTENSION_FILES = extension.c extensioncreate.c extensiondelete.c \
- extensionident.c
-C_FILES = debug.c $(EXTENSION_FILES) fatal.c exinit.c io.c \
- itronapi.c posixapi.c rtemsapi.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
-
-OBJS = $(C_O_FILES)
-
-include $(top_srcdir)/automake/multilib.am
-include $(top_srcdir)/automake/compile.am
-include $(top_srcdir)/automake/lib.am
-
-#
-# Add local stuff here using +=
-#
-
-AM_CPPFLAGS += -D__RTEMS_INSIDE__
-
-all-local: ${ARCH} $(LIB)
-
-$(LIB): ${OBJS}
- $(make-library)
-
-EXTRA_DIST = $(C_FILES)
-
-include $(top_srcdir)/automake/local.am