summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-05-21 23:19:36 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-05-21 23:19:36 +0000
commit6f1384cd4ff2518fbbde7fe99f4cbc7112ec14fc (patch)
tree75216d7fabbbe051420f24832c803ac74418ee7d /cpukit/sapi/Makefile.am
parent2007-05-21 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-6f1384cd4ff2518fbbde7fe99f4cbc7112ec14fc.tar.bz2
Split Classic API data instantiation into individual files. This reduces the size of the BSS section when an optional manageer stub is used. Some tests showed about a 600 byte reduction in BSS size. Also eliminated the variables _RTEMS_tasks_User_initialization_tasks and _RTEMS_tasks_Number_of_initialization_tasks because they were only used in one place after initialized. It was a waste of space.
Diffstat (limited to '')
-rw-r--r--cpukit/sapi/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpukit/sapi/Makefile.am b/cpukit/sapi/Makefile.am
index edb845aca2..531d0e779a 100644
--- a/cpukit/sapi/Makefile.am
+++ b/cpukit/sapi/Makefile.am
@@ -22,7 +22,8 @@ AM_CPPFLAGS += -D__RTEMS_INSIDE__
noinst_LIBRARIES = libsapi.a
libsapi_a_SOURCES = src/debug.c src/extension.c src/extensioncreate.c \
src/extensiondelete.c src/extensionident.c src/fatal.c src/exinit.c \
- src/exshutdown.c src/io.c src/itronapi.c src/posixapi.c src/rtemsapi.c
+ src/exshutdown.c src/io.c src/itronapi.c src/posixapi.c src/rtemsapi.c \
+ src/extensiondata.c
libsapi_a_CPPFLAGS = $(AM_CPPFLAGS)
include $(srcdir)/preinstall.am