summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 15:02:25 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 15:02:25 +0000
commit6265b8306047c800ac84514601ffd05322db79d4 (patch)
tree81d3a31146f2767fc15300eca93fc217e45e0e06 /cpukit/sapi/Makefile.am
parentNew. (diff)
downloadrtems-6265b8306047c800ac84514601ffd05322db79d4.tar.bz2
Split preinstallation rules in to separate files (preinstall.am).
Diffstat (limited to '')
-rw-r--r--cpukit/sapi/Makefile.am57
1 files changed, 4 insertions, 53 deletions
diff --git a/cpukit/sapi/Makefile.am b/cpukit/sapi/Makefile.am
index da5190b043..233d8f3dae 100644
--- a/cpukit/sapi/Makefile.am
+++ b/cpukit/sapi/Makefile.am
@@ -5,6 +5,9 @@
include $(top_srcdir)/automake/multilib.am
include $(top_srcdir)/automake/compile.am
+CLEANFILES =
+DISTCLEANFILES =
+
include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = include/confdefs.h
@@ -31,58 +34,6 @@ libsapi_a_CPPFLAGS = $(AM_CPPFLAGS)
all-local: $(PREINSTALL_FILES)
-PREINSTALL_DIRS =
-PREINSTALL_FILES =
-
-$(PROJECT_INCLUDE)/rtems/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/rtems
- @: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-
-$(PROJECT_INCLUDE)/rtems/confdefs.h: include/confdefs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/confdefs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/confdefs.h
-
-$(PROJECT_INCLUDE)/rtems/config.h: include/rtems/config.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/config.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/config.h
-
-$(PROJECT_INCLUDE)/rtems/extension.h: include/rtems/extension.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/extension.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/extension.h
-
-$(PROJECT_INCLUDE)/rtems/fatal.h: include/rtems/fatal.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/fatal.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/fatal.h
-
-$(PROJECT_INCLUDE)/rtems/init.h: include/rtems/init.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/init.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/init.h
-
-$(PROJECT_INCLUDE)/rtems/io.h: include/rtems/io.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/io.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/io.h
-
-$(PROJECT_INCLUDE)/rtems/mptables.h: include/rtems/mptables.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/mptables.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/mptables.h
-
-$(PROJECT_INCLUDE)/rtems/sptables.h: include/rtems/sptables.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/sptables.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/sptables.h
-
-if INLINE
-$(PROJECT_INCLUDE)/rtems/extension.inl: inline/rtems/extension.inl $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/extension.inl
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/extension.inl
-
-else
-$(PROJECT_INCLUDE)/rtems/extension.inl: macros/rtems/extension.inl $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/extension.inl
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/extension.inl
-endif
-
-CLEANFILES = $(PREINSTALL_FILES)
-DISTCLEANFILES = $(PREINSTALL_DIRS)
+include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am