summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-21 11:29:01 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-22 09:40:23 +0100
commit15e19273b2a6ebda3b2d55b28d693e7b8a0740b2 (patch)
tree4fb0c67c21f6f9f947e5400fc0a40e03acff00eb /cpukit/sapi/Makefile.am
parentINTERNAL_ERROR_POSIX_INIT_THREAD_ENTRY_IS_NULL (diff)
downloadrtems-15e19273b2a6ebda3b2d55b28d693e7b8a0740b2.tar.bz2
sapi: New implementation of rtems_panic()
The previous rtems_panic() implementation was quite heavy weight. It depended on _exit() which calls the global destructors. It used fprintf(stderr, ...) for output which depends on an initialized console device and the complex fprintf(). Introduce a new fatal source RTEMS_FATAL_SOURCE_PANIC for rtems_panic() and output via vprintk(). Update #3244.
Diffstat (limited to '')
-rw-r--r--cpukit/sapi/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/sapi/Makefile.am b/cpukit/sapi/Makefile.am
index 85d89ef494..326d67f193 100644
--- a/cpukit/sapi/Makefile.am
+++ b/cpukit/sapi/Makefile.am
@@ -43,6 +43,7 @@ libsapi_a_SOURCES += src/delaynano.c
libsapi_a_SOURCES += src/rbtree.c
libsapi_a_SOURCES += src/rbtreefind.c
libsapi_a_SOURCES += src/rbtreeinsert.c
+libsapi_a_SOURCES += src/panic.c
libsapi_a_SOURCES += src/profilingiterate.c
libsapi_a_SOURCES += src/profilingreportxml.c
libsapi_a_SOURCES += src/tcsimpleinstall.c