summaryrefslogtreecommitdiffstats
path: root/cpukit/sapi/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-04 18:44:16 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-04 18:44:16 +0000
commitbd9baa8184e8ff78b6644e8d88817a3ac8ec67fe (patch)
tree626eb6aa1a8779330e88e16987c6f25c226507f6 /cpukit/sapi/Makefile.am
parent2011-04-04 Sebastien Bourdeauducq <sebastien.bourdeauducq@gmail.com> (diff)
downloadrtems-bd9baa8184e8ff78b6644e8d88817a3ac8ec67fe.tar.bz2
2010-07-28 Gedare Bloom <giddyup44@yahoo.com>
PR 1641/cpukit * sapi/Makefile.am, sapi/preinstall.am, score/Makefile.am, score/preinstall.am: Add Red Black Tree data structure to score. * sapi/include/rtems/rbtree.h, sapi/inline/rtems/rbtree.inl, score/include/rtems/score/rbtree.h, score/inline/rtems/score/rbtree.inl, score/src/rbtree.c, score/src/rbtreeextract.c, score/src/rbtreefind.c, score/src/rbtreefindheader.c, score/src/rbtreeget.c, score/src/rbtreeinsert.c, score/src/rbtreepeek.c: New files.
Diffstat (limited to 'cpukit/sapi/Makefile.am')
-rw-r--r--cpukit/sapi/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/cpukit/sapi/Makefile.am b/cpukit/sapi/Makefile.am
index fb35b914f0..6f9b4cc0fe 100644
--- a/cpukit/sapi/Makefile.am
+++ b/cpukit/sapi/Makefile.am
@@ -10,12 +10,13 @@ include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = include/confdefs.h
include_rtems_HEADERS += include/rtems/chain.h include/rtems/config.h \
include/rtems/extension.h include/rtems/fatal.h include/rtems/init.h \
- include/rtems/io.h include/rtems/mptables.h include/rtems/sptables.h
+ include/rtems/io.h include/rtems/mptables.h include/rtems/rbtree.h \
+ include/rtems/sptables.h
EXTRA_DIST = include/rtems/README
include_rtems_HEADERS += inline/rtems/chain.inl \
- inline/rtems/extension.inl
+ inline/rtems/extension.inl inline/rtems/rbtree.inl
## src
AM_CPPFLAGS += -D__RTEMS_INSIDE__