summaryrefslogtreecommitdiffstats
path: root/cpukit/rtems/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-05-25 14:09:46 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-05 07:08:40 +0200
commit7d7c50def0624db287a5b143a61c72a38f06683f (patch)
treeeccb3d6f387163203fa56c6e2de9d00f1878f3e7 /cpukit/rtems/Makefile.am
parentcapture: Use unlimited objects (diff)
downloadrtems-7d7c50def0624db287a5b143a61c72a38f06683f.tar.bz2
rtems: Move _Status_Object_name_errors_to_status
Move _Status_Object_name_errors_to_status to a separate file to avoid a dependency on errno. Dependencies to errno are hard to be removed by the linker garbage collection.
Diffstat (limited to '')
-rw-r--r--cpukit/rtems/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/rtems/Makefile.am b/cpukit/rtems/Makefile.am
index b8694b8022..7af4ec7deb 100644
--- a/cpukit/rtems/Makefile.am
+++ b/cpukit/rtems/Makefile.am
@@ -183,6 +183,7 @@ librtems_a_SOURCES += src/modes.c
librtems_a_SOURCES += src/status.c
librtems_a_SOURCES += src/statustext.c
+librtems_a_SOURCES += src/statustoerrno.c
librtems_a_SOURCES += src/getcurrentprocessor.c
librtems_a_SOURCES += src/getprocessorcount.c