summaryrefslogtreecommitdiffstats
path: root/cpukit/rtems/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 13:39:43 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 13:39:43 +0000
commit53a895846c4e76c6f5677e33bba0d16c5f4c5d68 (patch)
tree66edd92ef82792de037d63995eeaf447cf1c7b2a /cpukit/rtems/Makefile.am
parent2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-53a895846c4e76c6f5677e33bba0d16c5f4c5d68.tar.bz2
2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Use mkdir_p. Remove dirs from PRE/TMPINSTALL_FILES.
Diffstat (limited to '')
-rw-r--r--cpukit/rtems/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/cpukit/rtems/Makefile.am b/cpukit/rtems/Makefile.am
index d7835f44df..12d004040b 100644
--- a/cpukit/rtems/Makefile.am
+++ b/cpukit/rtems/Makefile.am
@@ -144,18 +144,16 @@ EXTRA_DIST = $(STD_C_FILES) $(MP_C_FILES)
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)
+ @$(mkdir_p) $(PROJECT_INCLUDE)
@: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
$(PROJECT_INCLUDE)/rtems.h: include/rtems.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems.h
$(PROJECT_INCLUDE)/rtems/rtems/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/rtems
+ @$(mkdir_p) $(PROJECT_INCLUDE)/rtems/rtems
@: > $(PROJECT_INCLUDE)/rtems/rtems/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/rtems/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/rtems/asr.h: include/rtems/rtems/asr.h $(PROJECT_INCLUDE)/rtems/rtems/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/rtems/asr.h