summaryrefslogtreecommitdiffstats
path: root/cpukit/rtems/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <jennifer.averett@oarcorp.com>2014-02-10 12:30:39 -0600
committerJennifer Averett <jennifer.averett@oarcorp.com>2014-03-07 09:10:01 -0600
commit29cacfdbf3a7b90ecb513a591f225e68f14ad340 (patch)
tree4e53d1371fe32f5cda0f7dc2098c674baf9f8edd /cpukit/rtems/Makefile.am
parentsapi: Moved smp initialization and added cpuset initilization. (diff)
downloadrtems-29cacfdbf3a7b90ecb513a591f225e68f14ad340.tar.bz2
rtems: Add Classic API get and set affinity methods.
Add the following methods: + rtems_task_get_affinity + rtems_task_set_affinity
Diffstat (limited to '')
-rw-r--r--cpukit/rtems/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/cpukit/rtems/Makefile.am b/cpukit/rtems/Makefile.am
index ea461deabc..f89a896f2d 100644
--- a/cpukit/rtems/Makefile.am
+++ b/cpukit/rtems/Makefile.am
@@ -269,5 +269,12 @@ librtems_a_SOURCES += src/signalmp.c
librtems_a_SOURCES += src/taskmp.c
endif
+## SMP Files
+if HAS_SMP
+librtems_a_SOURCES += src/tasksetaffinity.c
+librtems_a_SOURCES += src/taskgetaffinity.c
+endif
+
+
include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am