summaryrefslogtreecommitdiffstats
path: root/cpukit/rtems/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-03-28 19:56:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-03-28 19:56:14 +0000
commit4b6546f0bb2687af0463a855a78822785d656d6e (patch)
treee8fb6b77d7ad5d7a331684d0a8e35d59bc78b910 /cpukit/rtems/Makefile.am
parent2007-03-28 Chris Johns <chrisj@rtems.org> (diff)
downloadrtems-4b6546f0bb2687af0463a855a78822785d656d6e.tar.bz2
2007-03-28 Chris Johns <chrisj@rtems.org>
* rtems/Makefile.am, rtems/include/rtems/rtems/clock.h, score/include/rtems/score/watchdog.h: Add support for a handler to obtain the number of nanoseconds since the last clock tick. The primary interface for this is rtems_clock_set_nanoseconds_extension. Subsequent commits from Joel will redo the TOD support to use this capability. * rtems/src/clocksetnsecshandler.c: New file.
Diffstat (limited to 'cpukit/rtems/Makefile.am')
-rw-r--r--cpukit/rtems/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/rtems/Makefile.am b/cpukit/rtems/Makefile.am
index 7e9d3393e4..a12eef398f 100644
--- a/cpukit/rtems/Makefile.am
+++ b/cpukit/rtems/Makefile.am
@@ -77,7 +77,7 @@ librtems_a_SOURCES += src/barrier.c src/barriercreate.c src/barrierdelete.c \
## CLOCK_C_FILES
librtems_a_SOURCES += src/rtclock.c src/clockget.c src/clockset.c \
- src/clocktick.c
+ src/clocktick.c src/clocksetnsecshandler.c
## TIMER_C_FILES
librtems_a_SOURCES += src/rtemstimer.c src/timercancel.c src/timercreate.c \