summaryrefslogtreecommitdiffstats
path: root/cpukit/pppd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-10-26 16:22:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-10-26 16:22:49 +0000
commit8f19e3007c82e196a9ff5f44aee8966f6f12eb3f (patch)
tree566717375f04fb6739f744e8b8a5c4a10dff932d /cpukit/pppd/Makefile.am
parentRemove (unused). (diff)
downloadrtems-8f19e3007c82e196a9ff5f44aee8966f6f12eb3f.tar.bz2
Install rtemsdialer.h, rtemspppd.h to $(includedir)/rtems.
Diffstat (limited to '')
-rw-r--r--cpukit/pppd/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/cpukit/pppd/Makefile.am b/cpukit/pppd/Makefile.am
index 12c31ba31c..51c4ee59dc 100644
--- a/cpukit/pppd/Makefile.am
+++ b/cpukit/pppd/Makefile.am
@@ -4,23 +4,20 @@
include $(top_srcdir)/automake/compile.am
-noinst_LIBRARIES =
-
if HAS_NETWORKING
-include_HEADERS = rtemspppd.h rtemsdialer.h
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = rtemspppd.h rtemsdialer.h
-noinst_LIBRARIES += libpppd.a
+project_lib_LIBRARIES = libpppd.a
libpppd_a_SOURCES = auth.c ccp.c ccp.h chap.c chap.h chap_ms.c chap_ms.h \
chat.c demand.c fsm.c fsm.h ipcp.c ipcp.h lcp.c lcp.h magic.c magic.h \
options.c upap.c upap.h md4.c md4.h md5.c md5.h utils.c sys-rtems.c \
- rtemsmain.c rtemspppd.c pppd.h patchlevel.h pathnames.h
+ rtemsmain.c rtemspppd.c rtemspppd.h pppd.h patchlevel.h pathnames.h \
+ rtemsidialer.h
libpppd_a_CPPFLAGS = $(AM_CPPFLAGS) -D__BSD_VISIBLE
endif
-# FIXME: Move sources to libpppd_a_SOURCES, remove other files.
-EXTRA_DIST = ipxcp.c ipxcp.h
-
-all-local: $(PREINSTALL_FILES)
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
CLEANFILES = $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)