summaryrefslogtreecommitdiffstats
path: root/cpukit/pppd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-15 03:47:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-15 03:47:28 +0000
commit633456e9200c909c9aad6ab7fae50b70b829999d (patch)
treebc8567215cf86ce0c3c664215892de8ca2b31c35 /cpukit/pppd/Makefile.am
parent2004-01-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-633456e9200c909c9aad6ab7fae50b70b829999d.tar.bz2
2004-01-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Remove wrapup. * pppd/Makefile.am: Build libpppd. Use automake-compilation rules. * rtems_servers/Makefile.am: Build libftpd. Use automake-compilation rules. * rtems_telnetd/Makefile.am: Build libtelnetd. Use automake-compilation rules. * rtems_webserver/Makefile.am: Build libhttpd. Use automake-compilation rules. * wrapup/Makefile.am: Remove (Unused).
Diffstat (limited to 'cpukit/pppd/Makefile.am')
-rw-r--r--cpukit/pppd/Makefile.am40
1 files changed, 19 insertions, 21 deletions
diff --git a/cpukit/pppd/Makefile.am b/cpukit/pppd/Makefile.am
index 16e39017ae..38cc50908f 100644
--- a/cpukit/pppd/Makefile.am
+++ b/cpukit/pppd/Makefile.am
@@ -2,37 +2,35 @@
## $Id$
##
-LIBNAME = lib.a
-LIB = $(ARCH)/$(LIBNAME)
-
-C_FILES = auth.c ccp.c chap.c chap_ms.c chat.c demand.c fsm.c ipcp.c lcp.c \
- magic.c options.c upap.c md4.c md5.c utils.c sys-rtems.c rtemsmain.c \
- rtemspppd.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
include $(top_srcdir)/automake/compile.am
include $(top_srcdir)/automake/lib.am
-#
-# Add local stuff here using +=
-#
+CLEANFILES =
+EXTRA_LIBRARIES =
if HAS_NETWORKING
include_HEADERS = rtemspppd.h rtemsdialer.h
-$(LIB): $(OBJS)
- $(make-library)
+EXTRA_LIBRARIES += libpppd.a
+CLEANFILES += libpppd.a
+libpppd_a_SOURCES = auth.c ccp.c chap.c chap_ms.c chat.c demand.c fsm.c \
+ ipcp.c lcp.c magic.c options.c upap.c md4.c md5.c utils.c sys-rtems.c \
+ rtemsmain.c rtemspppd.c
+libpppd_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+
+EXTRA_LIBRARIES += libpppd_g.a
+CLEANFILES += libpppd_g.a
+libpppd_g_a_SOURCES = $(libpppd_a_SOURCES)
+libpppd_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-all-local: $(PREINSTALL_FILES) $(LIB)
+noinst_DATA = libpppd$(LIB_VARIANT).a
endif
-.PRECIOUS: $(LIB)
+# FIXME: Move sources to libpppd_a_SOURCES, remove other files.
+EXTRA_DIST = ccp.h chap.h chap_ms.h fsm.h ipcp.h ipxcp.c ipxcp.h lcp.c lcp.h \
+ magic.h md4.h md5.h patchlevel.h pathnames.h pppd.h upap.h
-EXTRA_DIST = auth.c ccp.c ccp.h chap.c chap.h chap_ms.c chap_ms.h chat.c \
- demand.c fsm.c fsm.h ipcp.c ipcp.h ipxcp.c ipxcp.h lcp.c lcp.h magic.c \
- magic.h md4.c md4.h md5.c md5.h options.c patchlevel.h pathnames.h \
- pppd.h rtemsdialer.h rtemsmain.c rtemspppd.c rtemspppd.h sys-rtems.c \
- upap.c upap.h utils.c
+all-local: $(PREINSTALL_FILES)
PREINSTALL_FILES =
@@ -51,6 +49,6 @@ $(PROJECT_INCLUDE)/rtemsdialer.h: rtemsdialer.h $(PROJECT_INCLUDE)/$(dirstamp)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtemsdialer.h
endif
-CLEANFILES = $(PREINSTALL_FILES)
+CLEANFILES += $(PREINSTALL_FILES)
include $(top_srcdir)/automake/local.am