summaryrefslogtreecommitdiffstats
path: root/cpukit/pppd/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-03 13:21:38 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-03 13:21:38 +0000
commit4bf1801d0d6fa7bcf7488f7f3cc5c39fafeac7d2 (patch)
tree5a28ef12908ea03bf2125df5b280ed1974dd02e5 /cpukit/pppd/Makefile.am
parentFixed spelling errors. (diff)
downloadrtems-4bf1801d0d6fa7bcf7488f7f3cc5c39fafeac7d2.tar.bz2
Patches rtems-rc-20000118-7.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that contains the automake files for libnetworking plus a couple of minor fixes. [Now only one unused/unsupported Makefile.in remains (./c/src/lib/libbsp/hppa1.1/pxfl/Makefile.in).] To apply: patch -p1 < rtems-rc-20000118-7.diff /bin/sh rtems-rc-20000118-7.rm /bin/sh rtems-rc-20000118-7.add ./bootstrap Notes: * I have tested this one by building all BSPs for m68k, powerpc, sh and unix with toolchains built since last weekend. * I did not touch libnetworking's directory layout.
Diffstat (limited to '')
-rw-r--r--cpukit/pppd/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/cpukit/pppd/Makefile.am b/cpukit/pppd/Makefile.am
new file mode 100644
index 0000000000..1c860d5a14
--- /dev/null
+++ b/cpukit/pppd/Makefile.am
@@ -0,0 +1,44 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+LIBNAME = lib.a
+LIB = $(ARCH)/$(LIBNAME)
+
+# What to do about main.c?
+C_FILES = auth.c cbcp.c ccp.c chap.c chap_ms.c chat.c demand.c fsm.c ipcp.c \
+ ipxcp.c lcp.c magic.c options.c upap.c md4.c md5.c rtems-ppp.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/lib.am
+
+#
+# Add local stuff here using +=
+#
+
+# DEFINES += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
+# -DBOOTP_COMPAT
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+EXTRA_FILES = modem_example/16550.h modem_example/README \
+ modem_example/modem.c modem_example/modem.h modem_example/ppp.c \
+ modem_example/ppp.h modem_example/pppcompress.c
+
+all-local: $(ARCH) $(OBJS) $(LIB)
+
+.PRECIOUS: $(LIB)
+
+EXTRA_DIST = README STATUS auth.c cbcp.c cbcp.h ccp.c ccp.h chap.c chap.h \
+ chap_ms.c chap_ms.h chat.c demand.c fsm.c fsm.h ipcp.c ipcp.h ipxcp.c \
+ ipxcp.h lcp.c lcp.h magic.c magic.h main.c md4.c md4.h md5.c md5.h \
+ options.c patchlevel.h pathnames.h ppp_tty.c pppd.h rtems-ppp.c upap.c \
+ upap.h $(EXTRA_FILES)
+
+include $(top_srcdir)/../../../automake/local.am