summaryrefslogtreecommitdiffstats
path: root/cpukit/pppd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-01-02 00:54:34 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-01-02 00:54:34 +0000
commit44213adda5068a7de678254c1df7500c46ae1f9c (patch)
tree87432cf421fe358b6983ab907fe427cb0ecb2dfe /cpukit/pppd/Makefile.am
parent2005-01-01 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-44213adda5068a7de678254c1df7500c46ae1f9c.tar.bz2
2005-01-01 Ralf Corsepius <ralf.corsepius@rtems.org>
* libnetworking/pppd/Makefile.am, libnetworking/rtems_servers/Makefile.am, libnetworking/rtems_telnetd/Makefile.am: Remove build-variant support.
Diffstat (limited to 'cpukit/pppd/Makefile.am')
-rw-r--r--cpukit/pppd/Makefile.am25
1 files changed, 8 insertions, 17 deletions
diff --git a/cpukit/pppd/Makefile.am b/cpukit/pppd/Makefile.am
index 0e278677f3..f7caca13a7 100644
--- a/cpukit/pppd/Makefile.am
+++ b/cpukit/pppd/Makefile.am
@@ -4,30 +4,21 @@
include $(top_srcdir)/automake/compile.am
-CLEANFILES =
-EXTRA_LIBRARIES =
+noinst_LIBRARIES =
if HAS_NETWORKING
include_HEADERS = rtemspppd.h rtemsdialer.h
-EXTRA_LIBRARIES += libpppd.a
-CLEANFILES += libpppd.a
-libpppd_a_SOURCES = auth.c ccp.c chap.c chap_ms.c chat.c demand.c fsm.c \
- ipcp.c lcp.c magic.c options.c upap.c md4.c md5.c utils.c sys-rtems.c \
- rtemsmain.c rtemspppd.c
+noinst_LIBRARIES += libpppd.a
+libpppd_a_SOURCES = auth.c ccp.c ccp.h chap.c chap.h chap_ms.c chap_ms.h \
+ chat.c demand.c fsm.c fsm.h ipcp.c ipcp.h lcp.c lcp.h magic.c magic.h \
+ options.c upap.c upap.h md4.c md4.h md5.c md5.h utils.c sys-rtems.c \
+ rtemsmain.c rtemspppd.c pppd.h patchlevel.h pathnames.h
libpppd_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-
-EXTRA_LIBRARIES += libpppd_g.a
-CLEANFILES += libpppd_g.a
-libpppd_g_a_SOURCES = $(libpppd_a_SOURCES)
-libpppd_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-
-noinst_DATA = libpppd$(LIB_VARIANT).a
endif
# FIXME: Move sources to libpppd_a_SOURCES, remove other files.
-EXTRA_DIST = ccp.h chap.h chap_ms.h fsm.h ipcp.h ipxcp.c ipxcp.h lcp.c lcp.h \
- magic.h md4.h md5.h patchlevel.h pathnames.h pppd.h upap.h
+EXTRA_DIST = ipxcp.c ipxcp.h
all-local: $(PREINSTALL_FILES)
@@ -49,7 +40,7 @@ $(PROJECT_INCLUDE)/rtemsdialer.h: rtemsdialer.h $(PROJECT_INCLUDE)/$(dirstamp)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtemsdialer.h
endif
-CLEANFILES += $(PREINSTALL_FILES)
+CLEANFILES = $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/automake/local.am