summaryrefslogtreecommitdiffstats
path: root/cpukit/pppd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-07-25 06:15:38 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-07-25 06:15:38 +0000
commit4078e82ae544f8eec4fcfa05aeb1bf38e3c40099 (patch)
tree6a0bb0d4328f968ebb772749af25426d39a8556a /cpukit/pppd/Makefile.am
parent2003-07-24 Jennifer Averett <jennifer.averett@OARcorp.com> (diff)
downloadrtems-4078e82ae544f8eec4fcfa05aeb1bf38e3c40099.tar.bz2
2003-07-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Remove (Merged into ../configure.ac). * .cvsignore, Makefile.am, pppd/Makefile.am, rtems_servers/Makefile.am, rtems_telnetd/Makefile.am, rtems_webserver/Makefile.am, wrapup/Makefile.am: Reflect having merged configure.ac into ../configure.ac
Diffstat (limited to '')
-rw-r--r--cpukit/pppd/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/cpukit/pppd/Makefile.am b/cpukit/pppd/Makefile.am
index b77fe30e4a..f03c0d604f 100644
--- a/cpukit/pppd/Makefile.am
+++ b/cpukit/pppd/Makefile.am
@@ -10,17 +10,21 @@ C_FILES = auth.c ccp.c chap.c chap_ms.c chat.c demand.c fsm.c ipcp.c lcp.c \
rtemspppd.c
OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-include $(top_srcdir)/../../../automake/compile.am
-include $(top_srcdir)/../../../automake/lib.am
+include $(top_srcdir)/../../automake/compile.am
+include $(top_srcdir)/../../automake/lib.am
#
# Add local stuff here using +=
#
+if HAS_NETWORKING
+include_HEADERS = rtemspppd.h rtemsdialer.h
+
$(LIB): $(OBJS)
$(make-library)
all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
+endif
.PRECIOUS: $(LIB)
@@ -30,12 +34,9 @@ lcp.c lcp.h magic.c magic.h md4.c md4.h md5.c md5.h options.c \
patchlevel.h pathnames.h pppd.h rtemsdialer.h rtemsmain.c rtemspppd.c \
rtemspppd.h sys-rtems.c upap.c upap.h utils.c
-include_HEADERS = rtemspppd.h rtemsdialer.h
-
-
PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
-include $(top_srcdir)/../../../automake/local.am
+include $(top_srcdir)/../../automake/local.am