summaryrefslogtreecommitdiffstats
path: root/cpukit/pppd/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-08-16 20:42:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-08-16 20:42:09 +0000
commit2f1b9304ac4ba89a2dcb6047cb584a5603a33987 (patch)
treef2339e3f2230b73ee4818d55d4154795e712d803 /cpukit/pppd/Makefile.am
parent2001-08-16 Mike Siers <mikes@poliac.com> (diff)
downloadrtems-2f1b9304ac4ba89a2dcb6047cb584a5603a33987.tar.bz2
2001-08-16 Mike Siers <mikes@poliac.com>
* Update of PPPD to 2.3.11 from 2.3.5 and addition of an example application. Mike's notes on the modifications: - renamed error() function because of namespace problems - removed calls to the exit() funciton - removed extra files from the pppd source directory - defined pppd task constant values in rtemspppd.h - modifyied example code to get actual tick per second value - placed the pppd 2.3.11 man page file (pppd.8) into the pppd directory * pppd/cbcp.c, pppd/cbcp.h, pppd/main.c, pppd/ppp_tty.c, pppd/pppmain.c, pppd/rtems-ppp.c, pppd/rtems-ppp.c: Deleted. * pppd/pppd.8, pppd/rtemsmain.c, pppd/rtemspppd.c, pppd/rtemspppd.h, pppd/sys-rtems.c, pppd/utils.c, pppd/example/Makefile, pppd/example/README, pppd/example/init.c, pppd/example/netconfig.h, pppd/example/ppp.conf, pppd/example/pppdapp.c, pppd/example/system.h: New files. * modem/ppp_tty.c, net/if_ppp.h, pppd/Makefile.am, pppd/README, pppd/STATUS, pppd/auth.c, pppd/ccp.c, pppd/ccp.h, pppd/chap.c, pppd/chap.h, pppd/chap_ms.c, pppd/chap_ms.h, pppd/chat.c, pppd/demand.c, pppd/fsm.c, pppd/fsm.h, pppd/ipcp.c, pppd/ipcp.h, pppd/ipxcp.c, pppd/ipxcp.h, pppd/lcp.c, pppd/lcp.h, pppd/magic.c, pppd/magic.h, pppd/options.c, pppd/patchlevel.h, pppd/pathnames.h, pppd/pppd.h, pppd/upap.c, pppd/upap.h: Modified.
Diffstat (limited to '')
-rw-r--r--cpukit/pppd/Makefile.am35
1 files changed, 18 insertions, 17 deletions
diff --git a/cpukit/pppd/Makefile.am b/cpukit/pppd/Makefile.am
index 836d2ab110..9aab295eb3 100644
--- a/cpukit/pppd/Makefile.am
+++ b/cpukit/pppd/Makefile.am
@@ -4,13 +4,13 @@
AUTOMAKE_OPTIONS = foreign 1.4
+
+
+
LIBNAME = lib.a
LIB = $(ARCH)/$(LIBNAME)
-# renamed main.c to pppmain.c
-C_FILES = auth.c cbcp.c ccp.c chap.c chap_ms.c chat.c demand.c fsm.c ipcp.c \
- ipxcp.c lcp.c magic.c options.c upap.c md4.c md5.c rtems-ppp.c \
- pppmain.c
+C_FILES = auth.c ccp.c chap.c chap_ms.c chat.c demand.c fsm.c ipcp.c lcp.c magic.c options.c upap.c md4.c md5.c utils.c sys-rtems.c rtemsmain.c rtemspppd.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
OBJS = $(C_O_FILES)
@@ -23,24 +23,25 @@ include $(top_srcdir)/../../../automake/lib.am
# Add local stuff here using +=
#
-# DEFINES += -D_COMPILING_BSD_KERNEL_ -DKERNEL -DINET -DNFS -DDIAGNOSTIC \
-# -DBOOTP_COMPAT
-
$(LIB): $(OBJS)
$(make-library)
-EXTRA_FILES = modem_example/16550.h modem_example/README \
- modem_example/modem.c modem_example/modem.h modem_example/ppp.c \
- modem_example/ppp.h modem_example/pppcompress.c
-
-all-local: $(ARCH) $(OBJS) $(LIB)
+all-local: $(PREINSTALL_FILES) $(ARCH) $(OBJS) $(LIB)
.PRECIOUS: $(LIB)
-EXTRA_DIST = README STATUS auth.c cbcp.c cbcp.h ccp.c ccp.h chap.c chap.h \
- chap_ms.c chap_ms.h chat.c demand.c fsm.c fsm.h ipcp.c ipcp.h ipxcp.c \
- ipxcp.h lcp.c lcp.h magic.c magic.h main.c md4.c md4.h md5.c md5.h \
- options.c patchlevel.h pathnames.h ppp_tty.c pppd.h rtems-ppp.c upap.c \
- upap.h pppmain.c $(EXTRA_FILES)
+EXTRA_DIST = auth.c ccp.c ccp.h chap.c chap.h chap_ms.c chap_ms.h \
+chat.c demand.c fsm.c fsm.h ipcp.c ipcp.h ipxcp.c ipxcp.h \
+lcp.c lcp.h magic.c magic.h md4.c md4.h md5.c md5.h options.c \
+patchlevel.h pathnames.h pppd.h rtemsmain.c rtemspppd.c rtemspppd.h \
+sys-rtems.c upap.c upap.h utils.c
+
+include_HEADERS = rtemspppd.h
+
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
include $(top_srcdir)/../../../automake/local.am