summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/src/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-09-13 13:23:37 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-09-13 13:23:37 +0000
commitbc51d7e98fa57916241751341364d0de3c05e850 (patch)
treef1864d1a492aeb58dd628c39fffa752e4644942d /cpukit/posix/src/Makefile.am
parent2001-09-13 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-bc51d7e98fa57916241751341364d0de3c05e850.tar.bz2
2001-09-13 Joel Sherrill <joel@OARcorp.com>
* src/mprotect.c: New file. Stub required by some gcc's to pass tests. In particular, about 350 ACATS tests fail if this is not present. * src/getpagesize.c: Ditto. * src/sysconf.c: Addition of Solaris value for _SC_STACK_PROT required to pass about 350 ACATS test cases. * src/Makefile.am: Added new files.
Diffstat (limited to 'cpukit/posix/src/Makefile.am')
-rw-r--r--cpukit/posix/src/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/cpukit/posix/src/Makefile.am b/cpukit/posix/src/Makefile.am
index 3df5b47f38..c841f96353 100644
--- a/cpukit/posix/src/Makefile.am
+++ b/cpukit/posix/src/Makefile.am
@@ -29,6 +29,8 @@ ID_C_FILES = getegid.c geteuid.c getgid.c getgroups.c getlogin.c getpgrp.c \
KEY_C_FILES = key.c keycreate.c keydelete.c keygetspecific.c \
keyrundestructors.c keysetspecific.c
+MEMORY_C_FILES = getpagesize.c mprotect.c
+
MESSAGE_QUEUE_C_FILES = mqueue.c mqueueclose.c mqueuecreatesupp.c \
mqueuedeletesupp.c mqueuegetattr.c mqueuenametoid.c mqueuenotify.c \
mqueueopen.c mqueuereceive.c mqueuerecvsupp.c mqueuesend.c \
@@ -77,10 +79,10 @@ TIME_C_FILES = time.c posixtimespecsubtract.c posixtimespectointerval.c \
TIMER_C_FILES = ptimer.c ptimer1.c
C_FILES = adasupp.c $(CANCEL_C_FILES) $(CONDITION_VARIABLE_C_FILES) \
- $(ID_C_FILES) $(KEY_C_FILES) $(MESSAGE_QUEUE_C_FILES) $(MUTEX_C_FILES) \
- $(PTHREAD_C_FILES) $(PSIGNAL_C_FILES) sched.c $(SEMAPHORE_C_FILES) \
- sysconf.c $(TIME_C_FILES) $(TIMER_C_FILES) types.c $(ENOSYS_C_FILES) \
- $(BUILD_FOR_NOW_C_FILES) utsname.c
+ $(ID_C_FILES) $(KEY_C_FILES) $(MEMORY_C_FILES) $(MESSAGE_QUEUE_C_FILES) \
+ $(MUTEX_C_FILES) $(PTHREAD_C_FILES) $(PSIGNAL_C_FILES) sched.c \
+ $(SEMAPHORE_C_FILES) sysconf.c $(TIME_C_FILES) $(TIMER_C_FILES) types.c \
+ $(ENOSYS_C_FILES) $(BUILD_FOR_NOW_C_FILES) utsname.c
C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
OBJS = $(C_O_FILES)