summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-31 16:33:48 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-31 16:33:48 +0000
commit781262bb5bd6f109e17e2c9a8515f1bb394f37c6 (patch)
tree2f29edc50e7a385213e266b3521bf6137a64db0d /cpukit/posix/include/Makefile.am
parent2000-10-29 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-781262bb5bd6f109e17e2c9a8515f1bb394f37c6.tar.bz2
2000-10-30 Joel Sherrill <joel@OARcorp.com>
* include/Makefile.am: Updated to reflect files merged into newlib. This resulted in some definitions moving to other files and thus some secondary effects in RTEMS source code. * include/unistd.h: Removed. Now use newlib's. * include/rtems/posix/mqueue.h: Add include of <signal.h>. * include/rtems/posix/threadsup.h: Add include of <sys/signal.h> * src/execv.c: Corrected prototype to agree with newlib. * src/execve.c: Corrected prototype to agree with newlib. * src/execvp.c: Corrected prototype to agree with newlib. * src/psignal.c: Rewrote reference to <siginfo.h> in comment since that file no longer exists. * src/pthreadkill.c: Added include of <signal.h>. * src/sigaction.c: Added include of <signal.h>. * src/sigtimedwait.c: Rewrote reference to <siginfo.h> in comment since that file no longer exists. *
Diffstat (limited to 'cpukit/posix/include/Makefile.am')
-rw-r--r--cpukit/posix/include/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/cpukit/posix/include/Makefile.am b/cpukit/posix/include/Makefile.am
index 387e599641..16db0edd0d 100644
--- a/cpukit/posix/include/Makefile.am
+++ b/cpukit/posix/include/Makefile.am
@@ -4,8 +4,7 @@
AUTOMAKE_OPTIONS = foreign 1.4
-## RTEMS unistd.h needs to be checked against newlib's and removed
-UNUSED_H_FILES = devctl.h intr.h unistd.h
+UNUSED_H_FILES = devctl.h intr.h
H_FILES = sched.h aio.h mqueue.h semaphore.h