summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-01-18 14:28:00 -0600
committerJoel Sherrill <joel@rtems.org>2016-01-18 14:28:00 -0600
commite39cdb875ce7458787b0be173f2f7893a774a673 (patch)
tree416cace7a5615149676367983f24daa39e0db9af /cpukit/posix/Makefile.am
parentChase Newlib sys/types.h / sys/select.h changes (diff)
downloadrtems-e39cdb875ce7458787b0be173f2f7893a774a673.tar.bz2
posix: Remove clock_getenable_attr() and clock_setenable_attr()
These were not implemented and it does not appear that they were ever officially part of an approved POSIX standard. They were likely part of the Draft 8 of POSIX 1003.1b that RTEMS pthreads were initially based upon. closes #2531.
Diffstat (limited to '')
-rw-r--r--cpukit/posix/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 89621fee59..5a63076cc7 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -194,8 +194,7 @@ libposix_a_SOURCES += src/pspin.c src/pspindestroy.c src/pspininit.c \
src/pspinunlock.c
## TIME_C_FILES
-libposix_a_SOURCES += src/adjtime.c \
- src/clockgetcpuclockid.c src/clockgetenableattr.c src/clocksetenableattr.c
+libposix_a_SOURCES += src/adjtime.c src/clockgetcpuclockid.c
## TIMER_C_FILES
libposix_a_SOURCES += src/ptimer.c src/timercreate.c src/timerdelete.c \