summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-11-30 17:35:46 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-11-30 17:35:46 +0000
commitde48a0ea91a7b1cd334d0e2d8a1a815f38993abc (patch)
treedef731ed89f06bac9ef47941197066815387ff35 /cpukit/posix/Makefile.am
parent2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-de48a0ea91a7b1cd334d0e2d8a1a815f38993abc.tar.bz2
2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add $(dirstamp) to compilation rules.
Diffstat (limited to '')
-rw-r--r--cpukit/posix/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 73a1050f54..d66c91bdf4 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -156,13 +156,13 @@ OBJS = $(C_FILES:src/%.c=${ARCH}/%.$(OBJEXT))
AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
-all-local: ${ARCH} $(PREINSTALL_FILES) $(LIB)
+all-local: $(PREINSTALL_FILES) $(LIB)
$(LIB): ${OBJS}
$(make-library)
endif
-${ARCH}/%.$(OBJEXT): src/%.c
+${ARCH}/%.$(OBJEXT): src/%.c $(ARCH)/$(dirstamp)
${COMPILE} -o $@ -c $<
# temporary so we can see how many things are left to implement