summaryrefslogtreecommitdiffstats
path: root/cpukit/posix/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2017-03-13 12:00:35 -0400
committerGedare Bloom <gedare@rtems.org>2017-05-05 10:34:08 -0400
commit8290f95cbdd5129561d8a375a223055ee7941116 (patch)
tree96d25c735f662d0bed0044d5dc88976b0e8e341b /cpukit/posix/Makefile.am
parentposix/shm: replace threadq with mutex (allocator lock) (diff)
downloadrtems-8290f95cbdd5129561d8a375a223055ee7941116.tar.bz2
posix: Add mmap/unmap support for mapping files.
This version of mmap comes from early work done on the RTL code base circa 2012. Update #2859.
Diffstat (limited to 'cpukit/posix/Makefile.am')
-rw-r--r--cpukit/posix/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/posix/Makefile.am b/cpukit/posix/Makefile.am
index 48617ccadf..3bb5bd29f9 100644
--- a/cpukit/posix/Makefile.am
+++ b/cpukit/posix/Makefile.am
@@ -32,6 +32,7 @@ include_HEADERS += include/mqueue.h
include_rtems_posix_HEADERS += include/rtems/posix/aio_misc.h
include_rtems_posix_HEADERS += include/rtems/posix/cond.h
include_rtems_posix_HEADERS += include/rtems/posix/condimpl.h
+include_rtems_posix_HEADERS += include/rtems/posix/mmanimpl.h
include_rtems_posix_HEADERS += include/rtems/posix/mqueue.h
include_rtems_posix_HEADERS += include/rtems/posix/mqueueimpl.h
include_rtems_posix_HEADERS += include/rtems/posix/mutex.h